ByteRay CQL Hub
← All queries

Installed Browser Extensions (Aggregate by Extension)

This query will output a table with all installed browser extensions.

CQL · Falcon Next-Gen SIEMCopy query
// Get browser extension event
#event_simpleName=InstalledBrowserExtension BrowserExtensionId!="no-extension-available"

// Aggregate by event_platform, BrowserName, ExtensionID and ExtensionName
| groupBy([event_platform, BrowserName, BrowserExtensionId, BrowserExtensionName], function=([count(aid, distinct=true, as=TotalEndpoints)]))

// Check to see if the extension is installed on fewer than 50 systems
| test(TotalEndpoints<50)

// Create a link to the Chrome Extension Store
| format("[See Extension](https://chromewebstore.google.com/detail/%s)", field=[BrowserExtensionId], as="Chrome Store Link")

// Sort in descending order
| sort(order=desc, TotalEndpoints, limit=1000)

// Convert the browser name from decimal to human-readable
| case{
    BrowserName="3" | BrowserName:="Chrome";
    BrowserName="4" | BrowserName:="Edge";
    *;
}
installed_browser_extensions__aggregate_by_extension_.yml
CrowdStrike
Hunting
Endpoint
Insight
2025-10-29
2025-10-29

Get this query running in your SIEM, with someone on call.

Our Managed SIEM team operates CrowdStrike Falcon Next-Gen SIEM in production, with over 350 battle-tested use cases and 24/7 incident response behind them.

Talk to the SIEM team