ByteRay CQL Hub
← All queries

Find tasks scheduled with ComHandler

CQL · Falcon Next-Gen SIEMCopy query
#event_simpleName=ScheduledTaskRegistered
| parseXml(TaskXml)
| ComHandlerData:=rename(Task.Actions.ComHandler.Data)
| ComHandlerData=* // Remove this line if you don't care if it's empty
| table([aid, ComHandlerData, TaskXml], limit=1000)
tasks_scheduled_with_ComHandler.yml
T1053.005
CrowdStrike
Hunting
Endpoint
Insight
2025-08-06
2025-08-28

Get this query running in your SIEM, with someone on call.

Our Managed SIEM team operates CrowdStrike Falcon Next-Gen SIEM in production, with over 350 battle-tested use cases and 24/7 incident response behind them.

Talk to the SIEM team