ByteRay CQL Hub
← All queries

Find hidden scheduled tasks

CQL · Falcon Next-Gen SIEMCopy query
#event_simpleName=ScheduledTaskRegistered
| parseXml(TaskXml)
| Hidden:=rename(Task.Settings.Hidden)
| Hidden=/true/i
| table([aid,Hidden,TaskXml],limit=1000)
hidden_scheduled_tasks.yml
T1053.005
CrowdStrike
Hunting
Endpoint
Insight
2025-08-06
2025-08-28

Get this query running in your SIEM, with someone on call.

Our Managed SIEM team operates CrowdStrike Falcon Next-Gen SIEM in production, with over 350 battle-tested use cases and 24/7 incident response behind them.

Talk to the SIEM team