EDRCHOKER - QoS Policy Abuse Targeting EDR/AV Processes
This rule detects attempts to impair defensive mechanisms by creating or modifying Quality of Service (QoS) policies that specifically target Endpoint Detection and Response (EDR) or Antivirus (AV) processes. Adversaries may use QoS policies to throttle network traffic for security products, hindering their ability to communicate with central management or cloud services, thus impairing their effectiveness.
// // EDRCHOKER - QoS Policy abuse targeting EDR/AV processes (T1562 – Impair Defenses)
// // https://www.zerosalarium.com/2026/06/edrchoker-choking-telemetry-stream-block-edr.html
// Author: Aamir Muhammad
|case{
#event_simpleName=/ProcessRollup2|WmiCreateProcess/iF
CommandLine=/New-NetQosPolicy|Set-NetQosPolicy/iF
CommandLine=/ThrottleRateActionBitsPerSecond|AppPathNameMatchCondition/iF
CommandLine=/(SenseIR\.exe|MsSense\.exe|MsMpEng\.exe|WinDefend\.exe|falcon-sensor\.exe|CSFalconService\.exe|SentinelService\.exe|SentinelAgent\.exe|CortexXDR\.exe|cyvera\.exe|pmsu\.exe|cb\.exe|carbonblack\.exe|edragent\.exe|HarfangLab\.exe|elastic-agent\.exe)/iF
| SuspectActivity := format( "QoS Policy Creation via Process Command Line: %s", field=[#event_simpleNam]);
#event_simpleName=/RegGenericValueUpdate|AsepValueUpdate|RegSystemConfigValueUpdate|RegistryHiveFileWritten|reg/iF
RegObjectName=/\\SOFTWARE\\Policies\\Microsoft\\Windows\\QOS/i
RegStringValue=/(SenseIR\.exe|MsSense\.exe|MsMpEng\.exe|WinDefend\.exe|falcon-sensor\.exe|CSFalconService\.exe|SentinelService\.exe|SentinelAgent\.exe|CortexXDR\.exe|cyvera\.exe|pmsu\.exe|cb\.exe|carbonblack\.exe|edragent\.exe|HarfangLab\.exe|elastic-agent\.exe)/i
| SuspectActivity := format("QoS Registry Manipulation targeting: %s", field=[RegStringValue])
}
|groupBy([@timestamp,ComputerName,FileName,ParentBaseFileName,CommandLine,#event_simpleName])The rule looks for command-line arguments used to create or set QoS policies (New-NetQosPolicy, Set-NetQosPolicy) that include throttling parameters (ThrottleRateActionBitsPerSecond, AppPathNameMatchCondition) and target common EDR/AV process names. It also detects direct registry modifications to QoS policies (\SOFTWARE\Policies\Microsoft\Windows\QOS) that include EDR/AV process names.
Reference: https://github.com/Aamir-Muhammad/CrowdStrike-Queries/blob/main/Hunting-Queries/edrchoker---qos-policy-abuse-targeting-edrav-processes.cql
